Application Name OpenOffice.org
Description word processor (Writer), spreadsheet (Calc), slide presentation (Impress); database (version 2 onwards), web editor (Writer), image manipulation (Draw), formula editor (Math).
Subject Area editors
Operating System(s) available for Windows / Mac OS X / Solaris / GNU/Linux
Software Dependencies
Hardware Dependencies
Licensing Types GNU GPL
Spoken languages supported many, see http://www.openoffice.org/dev_docs/source/1.0.1/index.html#localizations
Author and contact details OpenOffice.org
Related Software StarOffice, StarSuite (the Asian language version of StarOffice), Microsoft Office (Word, Excel, PowerPoint)
Standards Supported
Email addresses for support
WWW Info/Download http://www.openoffice.org

documentation:
http://www.openoffice.org/documentation.html
http://documentation.openoffice.org/
http://www.openoffice.org/faq.html

http://www.ooodocs.org/

FTP Download
Email addresses for discussion http://www.openoffice.org/mail_list.html
Email addresses for announcements http://www.openoffice.org/mail_list.html
Usenet discussion / support

IRC discussion / support #openoffice.org on irc.openprojects.net
Freely Distributable? yes
Saves Icons to
Files Copied to and Location
Keeps Log of Changes Installer Made in
Location of uninstaller(s)
Keeps a log file in
Registry areas used (HKLM/Software or HKCU/Software)
Cache characteristics
Command-Line Switches OpenOffice 1.x:
-net - install option for a multi-user setup
OpenOffice 2.0.x:
msiexec /a filename.msi - "Administrative install - Installs a product on the network"
Advice for when installing OpenOffice 1.x - to install the program so that multiple users may each have an independant configuration (on Windows 2000/XP):
  • install the OpenOffice program:
    • when you install, use 'setups -net'
    • Custom Installation
    • choose everything, unless you have specific reason not to
    • pick a program directory to copy files to (i.e. d:\programs\openoffice)
  • configure OpenOffice per-user:
    (doesn't need to be run with Administrative priviliges)
    • run d:\programs\openoffice\OpenOffice.org Setup or d:\programs\openoffice\program\soffice.exe
    • choose 'Workstation Installation'
    • choose a directory within the user's profile (i.e. c:\Documents & Settings\Administrator\Application Data\openoffice
    • OpenOffice will be configured for that user and icons placed on their Start Menu
Preference location(s)
[1] own profile
[2] Windows profile directory / self definable
[3] registry
OpenOffice 2.0.x:
- %APPDATA%\OpenOffice.org2\user\registry\data\org\openoffice\setup.xcu
- %APPDATA%\OpenOffice.org2\user\registry\data\org\openoffice\office\common.xcu


OpenOffice 1.x:
? OpenOffice-program-directory/program/instdb.inf and the same file in user's profile directory

User preferences
'User Data': user\config\registry\instance\org\openoffice\UserProfile.xml
Internet options: user\config\registry\instance\org\openoffice\Inet.xml

user\config\registry\instance\org\openoffice\Office\Common.xml
user\config\registry\instance\org\openoffice\DataAccess.xml
user\config\registry\instance\org\openoffice\Setup.xml
user\config\registry\instance\org\openoffice\office\Draw.xml
user\config\registry\instance\org\openoffice\office\Writer.xml
user\config\registry\instance\org\openoffice\office\WriterWeb.xml

Pre-configuration preferences
? share\config\registry\cache\instance\org\openoffice... *.dat
? share\config\registry\instance\org\openoffice\... *.xml
? user\config\registry\instance\org\openoffice\org\openoffice
Means of pre-configuring for multiple users
[1] own automated means of pre-config
[2] put in Default User (may have to point there too)
[3] create .reg file or run application and set prefs for template user account, both of which are manual tasks
OpenOffice 1.x

See 'Proposal for new network installation': http://www.openoffice.org/servlets/BrowseList?listName=discuss&by=subject&from=60455

We have menu configurations for OpenOffice 1.0.x saved in a file that can be imported to make the menus of OpenOffice Writer resemble those of Microsoft Word 97 to help those making the transition (though note that they will be out of sync with the integrated help and any OpenOffice books): http://www.openoffice.org/issues/show_bug.cgi?id=4734.
Likewise we have a toolbar configuration file

Is the menu bar pre-configurable by dropping this file into a user's profile?:
 C:\Documents and Settings\Administrator\Application Data\OOo\user\config\soffice.cfg\writermenubar.xml

http://installation.openoffice.org/
http://installation.openoffice.org/how_to_scp_oo.html


StarOffice 5.2 Installation with Response Files: http://installation.openoffice.org/01RESPONSE_SO52_final_rev2.pdf

OpenOffice OpenOffice 1.1 introduced these features related to preferences:
  • Central Java configuration for network installations
  • Central configuration store (registry)
  • Updating and patching via response file

Do preferences contain any user-specific data?
Preferences worth making (using application) Worthwhile changes to make from the default

OpenOffice 2.0.x
Tools -> AutoCorrect/AutoFormat...
  • Options -> URL Recognition -> turn off for [M] and [T]
Tools -> Options
  • OpenOffice.org
    • Print
      • Printer warnings -> Paper size - on
      • Printer warnings -> Paper orientation - on
    • Paths
      • Backups - My Documents
      • Templates - ?
These settings may be useful if you're not intending to use the native OpenOffice file formats:
  • Load/Save
    • General
      • Standard file format (if you're not using the native OpenOffice document format)
        • Text document - though it is best to use the native OpenOffice document format, some people may prefer to use Rich Text Format for exchanging with other people or even Microsoft Word 97/2000/XP
        • Spreadsheet - though it is best to use the native OpenOffice document format, some people may prefer to use Microsoft Excel 97/2000/XP for exchanging with other people
        • Presentation - though it is best to use the native OpenOffice document format, some people may prefer to use Microsoft PowerPoint 97/2000/XP for exchanging with other people
    • Microsoft Office
      • [/] [ ] MathType
      • [ ] [/] WinWord
      • [ ] [/] Excel
      • [ ] [/] PowerPoint

OpenOffice 1.1.x
Tools -> Options
  • OpenOffice.org
    • General
      • Help Agent -> Activate - off
    • Print
      • Printer warnings -> Paper size - on
      • Printer warnings -> Paper orientation - on
    • Paths
      • Backups - My Documents
      • Templates
    • Security
      • Java - Enable - off
  • Load/Save
    • General
      • AutoSave every - 15 minutes - on
      • Standard file format (if you're not using the native OpenOffice document format)
        • Text document - though it is best to use the native OpenOffice document format, some people may prefer to use Rich Text Format for exchanging with other people or even Microsoft Word 97/2000/XP
        • Spreadsheet - though it is best to use the native OpenOffice document format, some people may prefer to use Microsoft Excel 97/2000/XP for exchanging with other people
        • Presentation - though it is best to use the native OpenOffice document format, some people may prefer to use Microsoft PowerPoint 97/2000/XP for exchanging with other people
    • Microsoft Office - these settings may be useful if you're not intending to use the native OpenOffice file formats:
      • [/] [ ] MathType
      • [ ] [/] WinWord
      • [ ] [/] Excel
      • [ ] [/] PowerPoint
  • Language Settings
    • Languages -> Locale setting -> set yours here (i.e. English (UK))
    • Languages -> Default languages for documents -> Western -> set yours here (i.e. English (UK))
    • install the spellchecker dictionary for the language you want to use, if it isn't automatically installed by OpenOffice, then:
      Writing Aids -> Available language modules -> choose OpenOffice MySpell SpellChecker -> Edit -> pick your language from the drop-down list -> if available, put a tick in Spelling -> OpenOffice MySpell SpellChecker
Tools -> AutoCorrect/AutoFormat...
  • Options -> URL Recognition -> turn off for [M] and [T]

OpenOffice 1.0.x

Preferences
Tools -> Options
  • OpenOffice.org
    • General
      • Help Agent -> Activate - off
    • View
      • Display / View -> Inactive menu items - on (on by default in OpenOffice 1.1.x)
    • Print
      • Printer warnings -> Paper size - on
      • Printer warnings -> Paper orientation - on
    • Paths
      • Backups - My Documents
      • Templates
    • Security
      • Java - Enable - off
  • Load/Save
    • General
      • AutoSave every - 15 minutes - on
      • Standard file format (if you're not using the native OpenOffice document format)
        • Text document - though it is best to use the native OpenOffice document format, some people may prefer to use Rich Text Format for exchanging with other people or even Microsoft Word 97/2000/XP
        • Spreadsheet - though it is best to use the native OpenOffice document format, some people may prefer to use Microsoft Excel 97/2000/XP for exchanging with other people
        • Presentation - though it is best to use the native OpenOffice document format, some people may prefer to use Microsoft PowerPoint 97/2000/XP for exchanging with other people
    • Microsoft Office - these settings may be useful if you're not intending to use the native OpenOffice file formats:
      • [/] [ ] MathType
      • [ ] [/] WinWord
      • [ ] [/] Excel
      • [ ] [/] PowerPoint
  • Language Settings
    • Languages -> Locale setting -> set yours here (i.e. English (UK))
    • Languages -> Default languages for documents -> Western -> set yours here (i.e. English (UK))
    • install the spellchecker dictionary for the language you want to use, if it isn't automatically installed by OpenOffice, then:
      Writing Aids -> Available language modules -> choose OpenOffice MySpell SpellChecker -> Edit -> pick your language from the drop-down list -> if available, put a tick in Spelling -> OpenOffice MySpell SpellChecker
Tools -> AutoCorrect/AutoFormat...
  • Options -> URL Recognition -> turn off for [M] and [T]

Menu
(you can download these via http://www.openoffice.org/issues/show_bug.cgi?id=4734)

Toolbars
right-click on the Function bar -> Visible Buttons -> (turn off):
  • Load URL
  • Stop Loading
  • Edit File
  • Navigator On/Off
  • Gallery
to mimick Microsoft Word 2000, combine the Function Bar and Main Toolbar, then remove the Main Toolbar (Microsoft Office 2000 uses:  new, open, save, [search] / print, print preview, spelling and grammer / cut, copy, paste, [format painter] / undo, redo / insert hyperlink, [tables and borders], insert table, [insert Microsoft Excel worksheet], columns, drawing, [document map], show/hide *, zoom, Microsoft Word help, toolbar options. (items in [] haven't been added to our template yet)
OpenOffice's default suggested icons for 'Show Draw Functions', 'Nonprinting Characters On/Off' and 'Zoom' are too dark and lead the eye away

Preferences worth making (using preference file, if appropriate) and version number they apply to
Preferences worth making (using registry file, if appropriate) and version number they apply to
Notes Per-installation version information is kept in instdb.inf
Each user has a list of profiles and the different versions/installations of OpenOffice they relate to in sversion.ini
from template version 3.0